Neustar Registry Connections
Incident Report for OpenSRS
Resolved
Neustar has confirmed that the network issues they were experiencing have now been resolved. There should be no issues with the management of the .BIZ, .US, .CO, and .NYC TLDs. Thank you for your patience in this matter.
Posted Jun 12, 2015 - 11:42 UTC
Investigating
We are currently experiencing intermittent issues connecting to the Neustar registry, which provide the .BIZ, .US, .CO, and .NYC TLDs, and so this may impact the management of existing domains and new orders under those TLDs. The registry has been contacted and they confirmed that they are experiencing network issues. We will provide an update as soon as possible.
Posted Jun 12, 2015 - 10:47 UTC
This incident affected: Domain Services (Core gTLDs, Core ccTLDs, Other gTLDs, Other ccTLDs).