Comodo Services
Incident Report for OpenSRS
Resolved
The intermittent connectivity issues we've been seeing with Comodo have now been resolved. This was due to a configuration issue on our end which was addressed today. Thank you for your patience during this matter.
Posted Sep 21, 2015 - 18:00 UTC
Investigating
We are currently experiencing connectivity issues to Comodo.
You may experience errors when attempting to purchase/renew Comodo services at this time.

We have reached out to Comodo for more information on the issue.
Posted Sep 18, 2015 - 02:59 UTC
This incident affected: SSL.