Minds + Machines Registry Connections
Incident Report for OpenSRS
Resolved
We are happy to report that the connection issues we were experiencing with the Minds + Machines registry are now resolved. Thank you for your patience in this matter.
Posted Dec 13, 2015 - 20:42 UTC
Investigating
We are currently experiencing connection issues with Minds + Machines. Our operations team is investigating the issue.

This affects registrations, renewals, and management of Minds + Machines domains. Existing domains will continue to resolve normally.

Please see the link below for the affected TLDs:
https://goo.gl/42e4Jj
Posted Dec 13, 2015 - 16:37 UTC
This incident affected: Domain Services (Other gTLDs).