OpenSRS Chat Support
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted Sep 19, 2016 - 14:08 UTC
Monitoring
We are happy to report the live chat system is back online. We will continue to actively monitor the situation should any other issues arise.
Posted Sep 19, 2016 - 10:47 UTC
Investigating
We are current investigating connection issues with our live chat customer service platform. We are still available via help@opensrs.com and by phone 1 888 511 7284 (North America) +800 371 69922 (International).

We apologize for this inconvenience and appreciate your patience
Posted Sep 19, 2016 - 10:16 UTC
This incident affected: Reseller Support.