Cluster B - Connection Issues
Incident Report for OpenSRS
Resolved
We are happy to report that the connection issues we were facing on Cluster B have now been resolved.
Posted Jul 05, 2015 - 22:58 UTC
Identified
Our network operations team is currently investigating connection issues to cluster B which is currently impacting webmail, IMAP, and POP3 connections.
Posted Jul 05, 2015 - 22:35 UTC
This incident affected: Hosted Email (Cluster B).