OpenSRS Phone Support
Incident Report for OpenSRS
Resolved
The issues were resolved shortly after we noticed them, and so phone support has now been fully restored.
Posted Nov 05, 2015 - 07:52 UTC
Investigating
Our customer service telephone provider, Five9, is currently offline and we are unable to take your phone calls. We are working with them to resolve the problem. We are still available via email to help@opensrs.com, as well as live chat- https://opensrs.com/why/contact/. We apologize for this inconvenience and we appreciate your patience
Posted Nov 05, 2015 - 07:46 UTC
This incident affected: Reseller Support.