Cluster A Inbound Email
Incident Report for OpenSRS
Resolved
We are happy to report that the inbound email flow in Cluster A is now back to normal.
Posted Jul 22, 2015 - 00:32 UTC
Investigating
We are currently experiencing issues with the Inbound email flow on our Hosted Email Cluster A where the inbound service is degraded. We are still investigating, and we will provide an update as soon as possible.
Posted Jul 21, 2015 - 23:24 UTC
This incident affected: Hosted Email (Cluster A).