OpenSRS Phone Support
Incident Report for OpenSRS
Resolved
We're happy to report that the issues we were seeing with incoming calls was resolved earlier this evening. Thank you for your patience in the matter.
Posted May 09, 2016 - 23:43 UTC
Update
This issue has been narrowed down to calls originating from Bell Canada. Incoming calls from Bell Canada to our phone provider may fail. All other providers are unaffected. More updates will be provided as the investigation progresses.
Posted May 09, 2016 - 20:20 UTC
Investigating
We are currently experiencing an issue with our customer service telephone provider, and are unable to take incoming phone calls. We are working with them to resolve the problem. We are still available via email to help@opensrs.com, as well as live chat- https://opensrs.com/why/contact/. Thank you for your patience in the matter.
Posted May 09, 2016 - 19:10 UTC
This incident affected: Reseller Support.