Comodo Services
Incident Report for OpenSRS
Resolved
We're happy to report that the connectivity issues we were experiencing with Comodo have been resolved. Thank you for your patience in the matter.
Posted Oct 19, 2016 - 00:08 UTC
Investigating
We are currently experiencing connectivity issues with Comodo. You may experience errors when attempting to purchase/renew Comodo services at this time. We've reached out to Comodo and hope to have a resolution shortly.
Posted Oct 18, 2016 - 16:19 UTC
This incident affected: SSL.