Nominet Registry Connections
Incident Report for OpenSRS
Resolved
We are happy to report that the intermittent connection issues we were facing with Nominet have now been resolved.
Posted Sep 05, 2015 - 19:54 UTC
Investigating
We are currently experiencing intermittent connection issues with Nominet. This affects registrations, renewals, and updates of domains names. Existing domains will continue to resolve. Further updates will be provided as we investigate the issue.

The following TLDs are affected:
.cymru
.uk
.wales
Posted Sep 05, 2015 - 17:12 UTC
This incident affected: Domain Services (Core ccTLDs).