Neustar Registry Connections
Incident Report for OpenSRS
Resolved
Our connections to the registry have all been restored and service is fully online. Thanks for your patience in this matter.
Posted about 1 month ago. Jan 11, 2017 - 15:20 UTC
Investigating
We are currently experiencing connection issues with the Neustar registry due to extended maintenance. Our operations team is investigating the issue.

This affects registrations, renewals, and management of Neustar domains. Existing domains will continue to resolve normally.

Please see the link below for the affected TLDs:
https://goo.gl/42e4Jj
Posted about 1 month ago. Jan 11, 2017 - 14:42 UTC
This incident affected: Domain Services (Core ccTLDs, Other gTLDs, Other ccTLDs).