Inbound Mail Delivery Cluster A
Incident Report for OpenSRS
Resolved
We are happy to report that the issue with inbound mail delays has been resolved by our operations team.
Service is back online and fully operational.
Posted Jun 09, 2015 - 21:19 UTC
Investigating
We are currently experiencing inbound mail delays. Some user may experience problem using webmail, pop and imap services.

Our operations team has been engaged and is working on the issue. We will report back as soon as we get a resolution or update.
Posted Jun 09, 2015 - 20:59 UTC
This incident affected: Hosted Email (Cluster A).