Minds + Machines Registry Connections
Incident Report for OpenSRS
Resolved
We are happy to report that our connections to Minds + Machines have been restored. All TLDs are operational. Thank you for your patience in this matter.
Posted Jun 24, 2016 - 18:06 UTC
Investigating
We are currently experiencing registry connection issues with Minds + Machines. This affects registrations, renewals, and updates to domain names. The registry has been engaged.

Please see the link below for the affected TLDs:
https://goo.gl/42e4Jj
Posted Jun 24, 2016 - 14:21 UTC
This incident affected: Domain Services (Other gTLDs).