OpenSRS Website
Incident Report for OpenSRS
Resolved
We’re happy to report that opensrs.com is back online. We appreciate your patience in the matter.
Posted Apr 27, 2016 - 16:06 UTC
Investigating
There are currently issues with loading the opensrs.com website. We are working on getting this resolved. Reseller services are unaffected.
Posted Apr 27, 2016 - 15:57 UTC