Cluster B - Inbound Mail Delivery
Incident Report for OpenSRS
Resolved
We are happy to report that we have resolved the email delay issue within our system.
A small percentage of users would have started to experience delays as early as 1300hrs UTC.
All queued emails have now been sent out and new emails will be delivered immediately.
Posted Jul 07, 2015 - 16:25 UTC
Investigating
Users on Cluster B may experience delays receiving inbound email.
Our Operations team has been engaged and are working on the issue.
We will provide any new information as soon as it becomes available.
Posted Jul 07, 2015 - 14:28 UTC
This incident affected: Hosted Email (Cluster B).