Comodo Services
Incident Report for OpenSRS
Resolved
The connectivity issues with Comodo have now been resolved. The issue was resolved without any action from us and determined by Comodo to be an unscheduled maintenance.
Posted Apr 15, 2016 - 08:56 UTC
Investigating
We are currently experiencing connectivity issues to Comodo. You may experience errors when attempting to purchase/renew Comodo services at this time.

We are reaching out to Comodo as this isn't an expected outage.
Posted Apr 15, 2016 - 08:29 UTC
This incident affected: SSL.