OpenSRS Phone Support
Incident Report for OpenSRS
Resolved
We're happy to report that our phone service has been restored, and we can now receive inbound phone calls. Thank you for your patience.
Posted Apr 25, 2016 - 21:59 UTC
Investigating
We are currently experiencing an issue with our customer service telephone provider, and are unable to take incoming phone calls. We are working with them to resolve the problem. We are still available via email to help@opensrs.com, as well as live chat- https://opensrs.com/why/contact/. Thank you for your patience in the matter.
Posted Apr 25, 2016 - 21:35 UTC
This incident affected: Reseller Support.