OpenSRS Helpdesk
Incident Report for OpenSRS
Resolved
The issue with our "help.opensrs.com" website has been resolved. We will continue to actively monitor the situation should any other issues arise.

We apologize for the inconvenience, and thank you for your patience.
Posted Mar 16, 2017 - 00:04 UTC
Investigating
There are currently issues with loading the help.opensrs.com website. We are working with our helpdesk vendor to get this resolved. Reseller services are unaffected.
Posted Mar 15, 2017 - 19:44 UTC
This incident affected: Reseller Support.