Neustar Registry Connections
Incident Report for OpenSRS
Resolved
We are happy to report that the connection issues we were experiencing with the Neustar Registry are now resolved. We will continue to monitor the situation to ensure we do not experience any further issues. Thank you for your patience in this matter.
Posted Dec 23, 2016 - 19:04 UTC
Investigating
We are currently experiencing connection issues with the Neustar registry. Our operations team is investigating the issue.

This affects registrations, renewals, and management of .BIZ, .CN, .CO, .TEL, .US, and .MOE domains. Existing domains will continue to resolve normally.
Posted Dec 23, 2016 - 17:42 UTC
This incident affected: Domain Services (Other gTLDs).