This incident has been resolved. Services are fully recovered.
Start Time: 11/14/2024 13:26 UTC End Time: 11/14/2024 17:36 UTC
Posted Nov 14, 2024 - 19:11 UTC
Update
We are continuing to monitor the results. Services remain stable.
Posted Nov 14, 2024 - 18:32 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2024 - 17:31 UTC
Update
Some users may continue to have intermittent issues accessing Webmail on Cluster A. This may impact users logging into Webmail, and have intermittent sluggish response while using the webmail service.
We will keep you informed as we work on this, and appreciate your patience.
Posted Nov 14, 2024 - 16:09 UTC
Investigating
We have received reports of some users having intermittent issues accessing webmail, sending and recieving. Teams have been engaged and are investigating.
Posted Nov 14, 2024 - 15:28 UTC
This incident affected: Hosted Email (Cluster A, Webmail).