Cluster A - Inbound Delays
Incident Report for OpenSRS
Resolved
We are happy to report that our backlog has finally cleared as of the following times:

Incident Start Time: 08-01-2023 14:56:00
Incident End Time:08-01-2023 18:10:00
Total Duration: 3 hours, 14 minutes

This incident is now resolved.
Posted Aug 01, 2023 - 18:18 UTC
Identified
Our hosted email team has found the error causing delays. At this time the issue has been resolved and we are awaiting for the queue backlog to clear. We will continue to update as we go. Thank you for your patience.
Posted Aug 01, 2023 - 17:04 UTC
Update
Our Engineering team continues their work to resolve the delays with receiving emails.
Posted Aug 01, 2023 - 16:46 UTC
Investigating
We are currently experiencing inbound mail delays on Cluster A. Our engineering team is investigating the issue.

We will provide an update once we have additional information.
Posted Aug 01, 2023 - 15:37 UTC
This incident affected: Hosted Email (Cluster A).