Cluster A - Webmail login issues
Incident Report for OpenSRS
Resolved
The issue is now resolved and the email services are now functioning as expected.
Posted Dec 11, 2023 - 14:27 UTC
Investigating
We are investigating an issue preventing a subset of users on Cluster A from logging into Webmail. Our engineering team has been engaged.

We will provide an update once we have additional information.
Posted Dec 11, 2023 - 12:03 UTC
This incident affected: Hosted Email (Cluster A).