Connectivity issues with Afnic TLD (.museum)
Incident Report for OpenSRS
Resolved
All connections has been restored without any intervention. We are still awaiting a response from the registry. Further details will be updated in the incident request. We thank you for your patience.

Incident Start Time: 05-04-2021 05:05:00 UTC
Incident End Time:05-04-2021 08:01:00 UTC
Total Duration:1 hour and 56 minutes
Posted May 04, 2021 - 08:44 UTC
Investigating
We are experiencing connection issues to the registry. We will provide an update shortly with additional information.
Posted May 04, 2021 - 05:33 UTC
This incident affected: Domain Services (Other gTLDs).