The .EU connection issue has been resolved. All services are online.
Start Time: 11/20/2024 09:15 UTC End Time: 11/20/2024 11:15 UTC
Posted Nov 20, 2024 - 15:53 UTC
Update
We are continuing to have connection issues with the .EU Registry. We are waiting for any updates, and will keep you informed as they're made available to us.
Posted Nov 20, 2024 - 14:25 UTC
Investigating
We are currently investigating this issue.
Posted Nov 20, 2024 - 13:07 UTC
Identified
We have been notified by the .EU Registry, they are currently experiencing technical issues and are working to resolve them as quickly as possible.
We will keep you informed of any updates as they work to identify and resolve this issue.
Posted Nov 20, 2024 - 13:07 UTC
Investigating
We are currently experiencing connection issues with the .EU registry. Our engineering team is investigating the issue.
This affects registrations, renewals, and management of .EU domains. Existing domains will continue to resolve normally.
Posted Nov 20, 2024 - 13:05 UTC
This incident affected: Domain Services (Core ccTLDs).