Domain Lookups Failing

Incident Report for OpenSRS

Resolved

All domain lookup services have been restored. The root cause was due to planned upgrades. This incident has been resolved.
Posted Mar 17, 2025 - 21:22 UTC

Investigating

Our engineers are investigating an issue that is causing domain lookups to fail. Further updates will be provided.
Posted Mar 17, 2025 - 20:55 UTC
This incident affected: APIs (OpenSRS API) and Control Panels (Reseller Control Panel, Classic RWI).