Sectigo portal connectivity issues
Incident Report for OpenSRS
Resolved
The issue has been resolved.

Incident Start Time: 07-20-2022 14:52:00
Incident End Time:07-20-2022 16:14:00
Total Duration:1 hour, 22 minutes
Posted Jul 20, 2022 - 16:47 UTC
Investigating
We are experiencing connectivity issues with Trust Sectigo/Comodo. Clients registered with Sectigo will not be able to authenticate SSL certificates. We have reached out to the vendor for an investigation.
Posted Jul 20, 2022 - 15:38 UTC
This incident affected: SSL.