Cluster A email
Incident Report for OpenSRS
Resolved
Our engineering team has implemented a fix to restore the services. All services are back to normal, and we are no longer experiencing any issues.

Incident Start Time: 02-14-2023 02:07:00 UTC
Incident End Time: 02-14-2023 04:00:00 UTC
Total Duration: 1 hour 53 minutes
Posted Feb 14, 2023 - 04:14 UTC
Investigating
We have been made aware of an issue affecting clients on Cluster A accessing the email.

Our team is engaged and investigating.
Posted Feb 14, 2023 - 03:13 UTC
This incident affected: Hosted Email (Cluster A, Webmail).