Phone Support Degredation

Incident Report for OpenSRS

Resolved

This incident has been resolved. Phone support has been restored.
Posted Oct 08, 2024 - 20:26 UTC

Identified

Our phone support provider has posted an update stating this issue now appears resolved. They are seeing an improvement on this as it recovers.
Posted Oct 08, 2024 - 20:04 UTC

Investigating

We are currently experiencing issues with our phone support service provider, which is affecting customers' ability to reach us by phone. For support please connect with us via chat or email for assistance until this is resolved. Thank you for your understanding.
Posted Oct 08, 2024 - 19:38 UTC
This incident affected: Reseller Support.