.IT TLD connection issues
Incident Report for OpenSRS
Resolved
This issue has now been resolved.

The registry confirmed an issue on their side of the connection which has been restored to operation.

Incident Start Time: 12-27-2023 12:36:00 UTC
Incident End Time:12-27-2023 14:54:00
Total Duration:2 hours and 18 minutes
Posted Dec 27, 2023 - 16:09 UTC
Investigating
We are experiencing an issue impacting .IT domain registrations and renewals.

Our engineers are currently investigating this and will provide further updates as they come
Posted Dec 27, 2023 - 13:49 UTC
This incident affected: Domain Services (Core ccTLDs).