Registrar Mail Delays
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted May 01, 2024 - 01:12 UTC
Update
Our engineers have resolved the Registrar Mail delays at this time.

Domain related emails are now being delivered as expected.

Start Time: 13:11 UTC 04/30/2024
End time: 20:51 UTC 04/30/2024
Duration: 7hours 40 minutes
Posted May 01, 2024 - 01:12 UTC
Update
We are still experiencing delays on verification emails. We will provide further updates on our status page as soon as new information becomes available.

Thank you for your patience and understanding.
Posted Apr 30, 2024 - 20:30 UTC
Investigating
We are experiencing delays on the registrar mail system used to relay registrant verification. Our engineering team has been engaged and are actively working to resolve this issue.
Posted Apr 30, 2024 - 18:43 UTC
This incident affected: System Messaging.