TrustWave Connections
Incident Report for OpenSRS
Resolved
We are happy to report that the earlier connectivity issue to TrustWave has been resolved.

TrustWave has confirmed they corrected an issue on their end where resources became unavailable.
Posted Jun 12, 2015 - 17:43 UTC
Investigating
We are currently experiencing connectivity issues with TrustWave. You may experience issues when attempting to purchase/renew any TrustWave products. We have engaged Trustwave about the issue. An update will be provided as soon as we have more information.
Posted Jun 12, 2015 - 16:14 UTC
This incident affected: SSL.