OpenSRS Phone Support
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted Oct 04, 2016 - 16:18 UTC
Monitoring
Inbound traffic to our toll-free number has now been restored. We will continue to monitor the case until a full resolution is confirmed.
Posted Oct 04, 2016 - 15:58 UTC
Investigating
We are currently investigating an issue in reaching OpenSRS support via our toll-free number. We are still available via help@opensrs.com, as well as live chat- https://opensrs.com/why/contact/.

We apologize for this inconvenience and appreciate your patience in the matter.
Posted Oct 04, 2016 - 14:45 UTC
This incident affected: Reseller Support.