.IT Registry Connections
Incident Report for OpenSRS
Resolved
This incident has been resolved.
Posted Mar 15, 2024 - 15:21 UTC
Identified
We can report that lookups are available again and registrations are now possible again. Our engineering team is still investigating the root cause.
Posted Mar 13, 2024 - 13:29 UTC
Update
At this time there is no new update to share as the investigation continues. We appreciate your continued patience.
Posted Mar 11, 2024 - 19:43 UTC
Investigating
We are currently having connection issues with the .IT registry. The registry might be experiencing a temporary outage or undergoing maintenance. Our engineering team is investigating and will update as soon as we hear back from the registry.

This affects registrations, renewals, and management of .IT domains. Existing domains will continue to resolve normally.

For a list of affected TLDs, please see: http://opensrs.help/chart
Posted Mar 11, 2024 - 15:31 UTC
This incident affected: Domain Services (Other ccTLDs).