.IT Registry Connections
Incident Report for OpenSRS
Resolved
We are happy to report that our connection to the .IT registry has been restored.
You will once again be able to submit and manage your .IT domain.
Posted Jun 07, 2015 - 13:30 UTC
Investigating
We are currently experiencing issues connecting to the .IT registry, which would impact the management of all existing .IT domains, and any new registration or transfer request orders. Our Operations team has reached out to the registry, and we will update you as soon as we have more information.
Posted Jun 07, 2015 - 11:32 UTC