Trustwave Services
Incident Report for OpenSRS
Resolved
We are happy to report that Trustwave has resolved the issue on their end.
Orders can once again be processed without issue.
Posted Jan 30, 2017 - 02:56 UTC
Investigating
We are currently experiencing connectivity issues to Trustwave.
You may experience errors when attempting to purchase/renew Trustwave services at this time.

We have reached out to Trustwave for more information on the issue.
Posted Jan 30, 2017 - 01:41 UTC
This incident affected: SSL.